tekumemo

てくてくめもめも

あしたはきっとすべてわすれてしまうかわまいさんのためのめも

データビジュアライゼーション

21 5

E2D3のグラフをAmebaOwendで表示させる

アメブロを運営するサイバーエージェント提供のブログ&ホームページ作成サービス AmebaOwnd(アメーバオウンド)だと、無料のプランでHTMLタグの埋め込みが可能。

というわけでE2D3のグラフを使ったWebページが無料で簡単につくれるので、E2D3のグラフを埋め込む部分の設定手順です。

続きを読む »
17 5

【ノンプログラマのための】E2D3開発環境準備手順 その2-Macの場合-

2.GitHubからコピーする

ブラウザでGitHubにアクセスし作業する

続きを読む »
14 5

【ノンプログラマのための】E2D3開発環境準備手順 その1-Macの場合-

1.開発環境の構築

ターミナル(黒い画面)で実行する

続きを読む »
11 5

npm install -g e2d3実行時にnodeのバージョン不足のエラーがでた

症状

npm install -g e2d3を実行したら、nodeのバージョンがたりない警告がでた

$ npm install -g e2d3
npm WARN engine e2d3@0.6.4: wanted: {"node":"~5.3.0"} (current: {"node":"4.4.3","npm":"2.15.1"})
/home/ubuntu/.nvm/versions/node/v4.4.3/bin/e2d3 -> /home/ubuntu/.nvm/versions/node/v4.4.3/lib/node_modules/e2d3/bin/e2d3
(省略)

状況

  • Cloud9のHTML5テンプレートで検証がてらnpm install -g e2d3を実行
  • Cloud9ではE2D3のグラフの開発作業はできません。(Excel自体が必要なため)

回避策

  • E2D3はNode.js.5.3.xが必要なので使用するNode.jsを5.3.0にバージョンアップした

E2D3:Wiki Setup E2D3 for development_ja
> 必要なもの Node.js 5.3.x
続きを読む »
10 5

npm install -g e2d3実行時にpermission関連の警告やエラーの行がいっぱい出た。

状況

警告やエラーの内容をみると、権限がたりないっぽい。

npm WARN checkPermissions Missing write access to /usr/local/lib/node_modules/e2d3/node_modules/basic-auth
npm ERR! Error: EACCES: permission denied, access '/usr/local/lib/node_modules/e2d3/node_modules/basic-auth'

回避策

sudoつけて再実行したらいけた

  • ×  $ npm install -g e2d3
  • ○  $ sudo npm install -g e2d3
続きを読む »
月別アーカイブ
楽天市場